Visit Open-E website
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Unknown Operand on RAID0 Degraded Bootup

  1. #1

    Red face Unknown Operand on RAID0 Degraded Bootup

    Hi chaps!

    I am running Open E on the 60 day trial at the moment with a view to purchasing the SE licence for home/SOHO SAN use. My current configuration is two RAID0 arrays composed of two 500Gb SATA disks each.

    Booting from USB, all is well and I have the arrays up, running and attached as iSCSI targets, NAS shares, etc.

    However, I started to experiment with disaster recovery scenarios (One of the key reasons I'm running a RAID SAN to begin with) and have run into an obstacle.

    When I remove one of the disks from the machine and boot it up, what I *expect* to happen is for OpenE to boot up and for the affected array to indicate that it is running in Degraded mode.

    What actually happens, is that a short way into the boot procedure (Maybe 5-6 seconds after the initial "LOADING"message appears) I am greeted with the following error:

    ash: 0: "unknown operand"
    It is worth noting that if I power down and reconnect the disk, the system boots normally.

    At present time there is no critical data on the system as I have only been conducting performance and system tests as part of a purchasing evaluation.

    Now, I'm not particularly well informed when it comes to all matters RAID (Hence why I'm using OpenE instead of building a SAN from scratch with a linux distro or such) so perhaps my expectations are misguided and the system is behaving as it should. I'm not convinced this is the case, though, so would very much appreciate some guidance on this matter!

    Kindest regards and many thanks in advance,

  2. #2


    (Ah, I forgot to mention that I am using OpenE software RAID, not a hardware controller!)

  3. #3


    Further testing...
    Booting with just one disk, managed to get OpenE online. Then added the disks one by one rescanning each time. All the disks detected (almost) correctly, but the arrays remained in Degraded mode and no indication could be found as to whether they were resyncing or not. Sitting and waiting did not help, they remained in degraded mode

    Interesting was that prior to this, the devices listed as S000, S001, S002 and S003. When bringing them on "hot" they listed as S000, S002, S003 and S004.

    Tomorrow I will be scrapping the lot and starting from scratch with the latest OpenE version on the site, as I am a couple of minor revisions behind. If I can't trust the darned thing to boot up if a disk fails then it's not much cop! There must be something amiss. Email alerts also failed, even though on initial setup I did receive the test email. That one may well be junk-filter related, though, and requires further investigation.

  4. #4


    You say you have raid 0?
    "My current configuration is two RAID0 arrays composed of two 500Gb SATA disks each."
    this is more jbod

    you may need to re-add the failed disk to the array.

    I would not use raid 0 as if you lose one drive all of your data will be lost.
    your data will be safer with raid 5

    see link below

    RAID 0
    RAID 0 (striped disks) distributes data across multiple disks in ways that gives improved speed at any given instant. If one disk fails, however, all of the data on the array will be lost, as there is neither parity nor mirroring. In this regard, RAID 0 is somewhat of a misnomer, in that RAID 0 is non-redundant. A RAID 0 array requires a minimum of two drives. A RAID 0 configuration can be applied to a single drive provided that the RAID controller is hardware and not software (i.e. OS-based arrays) and allows for such configuration. This allows a single drive to be added to a controller already containing another RAID configuration when the user does not wish to add the additional drive to the existing array. In this case, the controller would be set up as RAID only (as opposed to SCSI in non-RAID configuration), which requires that each individual drive be a part of some sort of RAID array.

  5. #5


    Apologies. I was unable to edit the post here, and in my tiredness got the wrong digit.

    They are RAID1 (Mirror) arrays.

    I could not re-add the disk, as Open-E labelled it as active as a "S/W RAID Part", but not part of any active array.

    I have re-written my flash drive with the latest version of OpenE and still cannot boot with any disks connected except for one.

    One booted I can re-add disks, but it is fraught with problems, sometimes it works, sometimes it doesn't.

    Currently on bootup with 4 drives connected I get UNKNOWN OPERAND again. On shutdown, sometimes it crashes with a white screen of death.

    Commercial deployment at this point looks highly unlikely, which is just my luck.

  6. #6


    Did you try to do your settings through the Console mode , by using an SSH software as putty ?
    you can connect by using username : cli and password use what you put it in SSH software password option).
    try to press CTRL+ALT+W , or CTRL+ALT+X and make your changes from there.
    also you can press F1 for shortcuts help.

    Also you said "When I remove one of the disks from the machine and boot it up...." and you are using RAID0 OR RAID1 , and both of this RAIDs must use 2 HDD at least!

    so your array are done with 2 HDD, and when you remove one , then you destroy the architecture that RAID work with ( as I know),
    so it’s not an Open-E error because you are doing something fully unexpected ! or am I wrong?
    it’s like someone try to run computer without RAM or CPU

  7. #7


    With a RAID1 (Mirror), if one disk fails the other should run the array in degraded mode. As there was no critical data on the array I was in the process of testing various scenarios, one of which was a critical absolute failure of a disk, simulated by booting the machine without the drive.

    That's when I ran into OpenE not booting with the "Unknown Operand" error, and have so far failed to both resolve it, and figure out what's causing it. The testing continues.

  8. #8


    what is happening is that open-e writes a serial number on the disk to keep track of them
    when you broke the raid 1 by removing the disk, the software was expecting a new disk drive to be added back to the raid

    by adding the just removed drive you are confusing the software.

    to keep you testing going, by reformat the drive so that there is nothing on it.
    (I know there is no data but the serial number is there)
    you can use the console utility in CRT-ALT-X "delete contants of unit"
    this will wipe the drive clean.

    also I think the software RAID does not support hot swap of the drives.
    (at least it did not when I tested this )

  9. #9


    Thankyou for the feedback Symm, some updates are warranted I think!

    - I am installing onto a 4Gb USB pen , "FAT" filesystem (Fat16) with the default chunk size. A friend of mine who uses OpenE from a USB pen uses a 2Gb drive, and when you do an openE install to a HDD it creates a 2Gb partition. I wondered if this was significant.

    - Initially, I powered down the machine, then removed the disk. It was not a "hot" removal. OpenE then failed to boot up, when you would _expect_ it to boot up, but to indicate that the affected array was now in degraded mode. However, it crashed on boot with an Unknown Operand error. Had that been a real scenario, with a disk losing power or plain old dying outright, I would have been locked out of my storage server and in a right mess! Lucky for me that I discovered this in testing, not in deployment.

    - Installing to a HDD has been so far successful, with the system booting up with 1 disk removed from a 4-disk array. This leads me toward there being a problem with either the USB pen in use, the machine's USB bus, or the fact that I'm using a 4Gb partition on the USB pen instead of 2.

    The testing continues.

  10. #10


    A further update for those following at home...

    Having installed OpenE onto a spare 20Gb PATA disk I am now seeing the expected behaviour and no more Unknown Operand errors.

    This has, at least, indicated that the problem lies somewhere between my CPU and USB pendrive. Whether it is the pendrive, the partition size, the USB bus on my motherboard... I am unable to say.

    Does anyone have any recommendation on the sector size I should format to when I format the pen drive? I have tried the darned thing in USB1.1 and USB2.0 mode, FAT32 and FAT16, still bouncing into errors.

    I have ordered a 2Gb drive just to test that theory also (Only 5, so worth a shot), if that one gives me the Unknown Operand trauma, then I'll have resign myself to adding another HDD to the system to run OpenE, or perhaps look to an IDE DOM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts