Visit Open-E website
Results 1 to 5 of 5

Thread: FC target failing with 3x ESXi4.1 initiators

Thread has average rating 5.00 / 5.00 based on 1 votes.
Thread has been visited 2567 times.
  1. #1

    Default FC target failing with 3x ESXi4.1 initiators


    I'm trying to build a mini version of what we have at work, for my home lab. I've chosen Open-E for my SAN provider, and I'm running 3 ESXi 4.1 hosts.

    My Open-E box has a dual port qlogic card, and my ESX boxes have EMulex 2g cards. I'm running a Qlogic SANbox 2, and a QLogic 3050 for two separate switches. I'm not familiar with SAN fabric design, so I am not sure if the two fabrics should be connected directly, so I haven't done that, but I dont think that's a problem, because I've also tried with only one path.

    OPEN-E is sharing out one LUN0 in the default group. I've got no masking or anything on the switches.. no security. ESXi boxes show two paths to the LUN, and can mount/format the disk on OPEN-E. Everything looks fine. I even SVMotioned one VM over to the Open-E box, and it worked, however, EVERY TIME I try to SVMotion another VM over to it, I get an error.. Sometimes the SAN goes offline, sometimes the existing machine on the SAN will still work, but most of the time it just dies, with esx saying the SAN failed / is unreachable. I can get it to come back up by switching the Open-E FC card to initiator mode and back, then ESXi sees it again, or I can reboot Open-E, so I suspect there's SOME kind of problem with my SAN setup.

    Like I said, I've tried with one path (one switch powered off, and/or one FC port on Open-E in initiator mode) with no change at all.

    In Open-E, I'm running a dual-core AMD proc on an ASUS MoBo, and my disks are two 2-tb drives mirrored on a hardware sata card.

    What else can I answer/provide so that someone might be able to point me in the right direction?!!

    Thanks in advance!!

  2. #2


    BTW.. The OPen-E is latest code.. says there's no upgrades available..

  3. #3
    Join Date
    Oct 2010


    try a second LUN on the target, so you have one vm per LUN.

  4. #4


    Quote Originally Posted by Gr-R
    try a second LUN on the target, so you have one vm per LUN.
    Is that a general recommendation with Open-E, or just a troubleshooting point? Based on the one VM working, I had kind of come to the same conclusion, and have now migrated that one VM off so that I can destroy and rebuild with multiple LUNs..

    The only problem is that without thin provisioning, which I can't find any mention of support for, that means I'm going to be doing a lot of managing the volume sizes as my machines grow, unless I'm missing something.

    I'm definitely going to try this, but I'm curious if this is generally a requirement with Open-E, or just a troubleshooting step for my issue?



  5. #5


    You mentioned that you have 3 ESX servers going to the same LUN - is the ESX servers setup in a HA? Is the Target / Qlogic dual port and you use just one port by specifying one to be initiator and the other a target then you might want to create a group and place the initiator WWN Alias for the LUN and test.
    All the best,

    Todd Maxwell

    Follow the red "E"
    Facebook | Twitter | YouTube

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts