Visit Open-E website
Results 1 to 5 of 5

Thread: How can I create 2x 2TB RAID-1 array???

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default How can I create 2x 2TB RAID-1 array???

    I just finished installing DSS V6 Lite and ran into an issue. I realize there is 2TB limit on storage, however I can't install my SW RAID. It says something about being over the 2TB limit. If I unplug 1 drive and reboot, all is well.

    Do I have to re-install, setup SW RAID with the unlimtited storage trial, make a 2TB RAID-1 volume, then activate the lite version???? seems rather silly!?!

    I am assuming if I was using HW RAID, that this would be ok, as it's only 2TB total.

    Any ideas on how to get the software RAID1 working?

  2. #2
    Join Date
    Jan 2011


    When using H/W RAID the DSS V6 Lite recognizes only the 2TB unit that is presented to the system. However when using the S/W RAID DSS V6 Lite counts all the capacity from all connected hard drives. So to create 2TB LUN using S/W RAID you will need e.g. 2x2TB hard drives, which exceeds the DSS V6 lite 2TB storage limit.
    You can use two 1TB hard drives and create 1TB RAID1 unit using S/W RAID.


  3. #3

    Default 2tb limit questions

    So.. I am having the same problem, and tried to get through it a different way, but I'm not sure what's going on...

    I basically put in a "throw away" 200g drive I just had laying around that I used as the OS install disk, and then used 3x 1tb drive in a HARDWARE raid 5 to give me 2tb to share over the FC.

    I was hoping the boot disk wouldn't be counted, and it would only count the HW Raid5 against the 2tb limit, but no such luck..

    I couldn't get my MoBo to boot off of the HW Raid (I hoped to just remove the 200g and use a partition on the HW Raid for boot) so I decided if I create only a 1.8tb partition, and waste 200g on my RAID, since its a HARDWARE raid, it should NOT be able to count the unused space, and it would add up to 2tb...

    Unfortunately, even after clicking rescan, it STILL says I'm over 2tb... SO.. just to make SURE I wasn't just slightly over 2tb with the 1.8 + 200gb, I re-created my RAID partition as 1.6tb, so I should be right around 1.8tb "visible" by the OS, but alas... it STILL says I'm over 2tb...

    There's GOT TO BE A WAY.. What am I missing here? is there ANY way to get an enumeration of the disks it's seeing, so that I can see if it's just caching old information somehow, or if it's hopeless because it's seeing the three 1tb drives that are the components of the 1.6 tb Raid-5???

    If it helps, I'm using a SiliconImage 6-port Hardware SATA Raid card.


  4. #4
    Join Date
    Aug 2010


    Did you tried to run the DSS Lite from a USB flash memory?
    If not, try that and remove the 200GB HDD that you used for installing the system. and let us know the result that you have.

  5. #5

    Default FC Initiator running...

    No - Haven't tried running from a USB stick yet, but I did make some progress..

    I took the 200g out of the box, and then re-initialized my raid completely to have a 2g partition 1, and the rest (1.9t) as partition 2....

    Booted from CD, and to my surprise, I saw THREE options for install..
    SDA: 2g
    SDB: 1999g
    SDC: 1250g

    There is DEFINITELY no other drives in there, so the ONLY thing I figured it could be is that it's detecting a FC LUN exposed by another machine on the switch. I proceeded to install on the 2G drive, and it did boot up, and confirm to me that the SDC drive was on another opensource SAN (I'm running OpenFiler, with some FC manual commands added in for FC support)

    My HOPE was that after I hardcoded both FC ports (dual port QLogic card) to be target mode, that this would go away, but it didn't... I also found a hardware setting in the QLogic driver config (on the console) that let me set "Initator mode" to NEVER start, but even that didn't stop the LUN from appearing.

    Now, I KNOW the RIGHT thing to do is to use some FC zoning to stop the LUN from appearing, but isn't there some way to tell Open-E that it's NOT going to use the LUNs it sees, and that I ONLY want it to be a target?

    Secondarily, I've got a second issue:
    The LUN from the Open-E server DOES show up, but with the wrong size...

    In VMWare I see a FC disk of 229 MEGS, when in the Open-E FC Target Manager, I have a LUN0 called LV0000, which shows as 1852.97G.

    I thought at first it was because it wasn't fully formatted or something, but I waited a day and did a rescan of ESX, and still have the same thing...

    So, I guess technically I maybe should have 2 threads going here, but do you have any idea on either issue?
    1: Shutting down initiator mode completely, and
    2; Why the target shows the wrong size?

    Thanks for your awesome quick responses!!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts