Visit Open-E website
Results 1 to 5 of 5

Thread: GID mapping problem / default group

  1. #1

    Default GID mapping problem / default group


    we have upgraded from NAS-XSR to DSSv6 lately.
    There were serveral users and shares configured over internal LDAP on the XSR.
    After installing DSSv6 we reimported UID and GID mappings, but there was a conflict with the GID mappings from the older XSR.
    The group id 101 wich was the Administrators group on the XSR is now the primary group "users". After importing the mappings both group have the id 101. As the Administrators group should not contain all users in the system and no two groups should have the same gid we tried a restart.
    After restart we were able to remove all groups except the users (primary) group.
    But then we weren't able to get any mappings (neither uid nor gid) downloaded.
    Now we have the users group left, but there seems to be no mapping existing.

    Is there any way to recover the group management functions without resetting the whole setup or configuration to factory defaults? Which group has the id 100? This group number is shown in the ACLs under Windows without any name.

    Thanks in advance.

    Best regards


  2. #2
    Pi-L Guest


    Nas-XSR as a very old system. It is possible that its settings will not be fully compatible with new DSS V6. I think the simplest solution to your problem would be to rename group 'users' to 'administrators', leave only users with administrator privileges in this group and move others to newly created group users with restricted rights. We could diagnose the exact problem via Remote Support if you could open a trouble ticket via user portal.

  3. #3


    Thanks for your fast reply.

    We managed to get the gids correct now, after switching to ADS and back to internal LDAP.
    Then we renamed users and created a new users group. But we needed to set the default group for any new user.

    After all this we tried to import the uid mappings (which worked before) and restarted.
    But now it is not possible to download neither the gid nor the (hopefully) changed uid mapping. When changing the imported file to utf-8 encoding it says "import failed".
    Do you know the problem of defective mappings? There seems to be a connection between the gid and uid import function. And without the mapping the access to the shares does"nt work. The used version is: 6.0up80.8101.5626

    Thanks in advance.


  4. #4


    Why are the uids for new users starting at 134?
    All users we need to map have a uid smaller than 130. Is there a collision with hidden users?

  5. #5
    Pi-L Guest


    There is a new implementation of it coming up soon, for now we have an small update with fix but it is not yet available for public so please open a ticket thru user portal and we will be able to send it to you via private mail.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts