Visit Open-E website
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: SR failed to complete operation-> LUN not found

Thread has average rating 5.00 / 5.00 based on 2 votes.
Thread has been visited 33719 times.
  1. #1

    Question SR failed to complete operation-> LUN not found

    I have set up a dss6lite system and created the Volumes etc. I also created the icsi targets, logical volumes etc, one time with Block I/O one time using File I/O. I always used the given namings just to do a basic setup.
    However, no chance to get the SR connected to XenServer 5.6SP2. The target IQN Scan was ok, the Target LUN Scan results in the error message, that SR failed to complete the operation.
    I am somehow confused.

    Can anybody get some light into this matter?
    thanks a lot.

  2. #2
    Join Date
    Aug 2010


    How much the size of your LUN ? is it more than 2TB ?

    Also did you tried to quit your ISCSI session and reconnect?

  3. #3


    the size is 1800 gb plus the overhead for replication etc.

    I did reconnect iscsi sesions, I also did restart both servers (dss server and Xenserver), no changes.

    iscsi_discovery (iscsi-ip) did work ok on the xen cli.

    the discovery of the LUN results in the mentioned error. The logfile from the xen /var/log/auditlog does give some wird information

    Nov 21 16:37:36 PCCO-XEN01 xapi: [20111121T15:37:36.503Z| info|PCCO-XEN01|3922|Async.SR.create R:742206fc7782|audit] ('trackid=717c3b128093ff2e954947c0d9bd241a' 'LOCAL_SUPERUSER' 'root' 'ALLOWED' 'ERROR:SR_BACKEND_FAILURE_96: [ ; The request is missing or has an incorrect target IQN parameter; <?xml version=\"1.0\" ?> <iscsi-target-iqns> <TGT> <Index> 0 </Index> <IPAddress> </IPAddress> <TargetIQN> iqn.2011-11:dss.target0 </TargetIQN> </TGT> <TGT> <Index> 1 </Index> <IPAddress> </IPAddress> <TargetIQN> * </TargetIQN> </TGT> </iscsi-target-iqns> ]' 'API' 'SR.create' (('host' 'PCCO-XEN01' 'fd04bab9-d233-40b4-8d43-e3baa25be4f5' 'OpaqueRef:06b501b6-8830-5dac-4a69-89b22b96ba44') ('name_label' '__gui__' '' '') ('name_description' 'SHOULD NEVER BE CREATED' '' '')))

    If this would be the first open-e iscsi, I would probably skip this experience an go back to local disks


  4. #4



    I have probbed the SR using CLI commands. here are the results: I am not able to receive the SCSIid back from the Target.

    [root@PCCO-XEN01 ~]#
    [root@PCCO-XEN01 ~]# xe sr-probe type=lvmoiscsi device-config:target= device-config:targetIQN=iqn.2011-11:dss.target0
    There was an SR backend failure.
    status: non-zero exit
    stderr: Traceback (most recent call last):
    File "/opt/xensource/sm/LVMoISCSISR", line 378, in ?, DRIVER_INFO)
    File "/opt/xensource/sm/", line 244, in run
    sr = driver(cmd, cmd.sr_uuid)
    File "/opt/xensource/sm/", line 128, in __init__
    File "/opt/xensource/sm/LVMoISCSISR", line 75, in load
    iscsi = driver(self.original_srcmd, sr_uuid)
    File "/opt/xensource/sm/", line 128, in __init__
    File "/opt/xensource/sm/", line 1135, in transform
    return func(inst, *args, **kwargs)
    File "/opt/xensource/sm/", line 167, in load
    File "/opt/xensource/sm/", line 170, in _initPaths
    File "/opt/xensource/sm/", line 236, in _init_adapters
    self.devs = scsiutil.cacheSCSIidentifiers()
    File "/opt/xensource/sm/", line 129, in cacheSCSIidentifiers
    line = "NONE %s %s %s %s 0 %s" % \
    IndexError: list index out of range

  5. #5
    Pi-L Guest


    You have to forgive me as I am not a XEN expert here, but here is some information about this error you can find on the net:

  6. #6


    Thanks for the link. I tried this patch, by then it did not even do the target scan.
    I re installed the dss6-lite plus created all volumes new.
    no chance.

    Looks like, I have a problem using dss6-lite with Citrix Xen 5.6SP2

  7. #7
    Pi-L Guest


    Have you tried other iSCSI Targets? I am just wondering how can we help you if this looks like Xen issue.

  8. #8
    Join Date
    Oct 2010


    can you show us your default initiator settings from Xen ??

  9. #9


    Hi Pi-L
    this is the problem, from this location, I have no other iSCSI Target available, the productiv iSCSI Targets are all in other locations separated in VLANS.
    I am trying bto figure out something, to get another Target available. Thought about the same thing yesterday. unfortunately, the Buffalo I am having here for NAS does not do iSCSI, only NFS.
    I also thought of this might be an XEN issue, however, have some trouble in fihuring out the real sourc of problems. Both systems are new and have never prouven to be ok.
    The XEN works with the NFS Share and the local store, The iSCSI open-e is ready prepared with the 1,8 TB Volume.

  10. #10


    try mabye something like:
    iqn.2011-11.dss.target0 or iqn.2011-11.dss:target0 as a name

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts