Visit Open-E website
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: SR failed to complete operation-> LUN not found

Thread has average rating 5.00 / 5.00 based on 2 votes.
Thread has been visited 33721 times.
  1. #11


    now you got me: where to check the default initiator setting? I tried to find the info in connection to the iscsi and see the connection status at the open-e status info page:

    I did a manuel discover and connect
    [root@PCCO-XEN01 ~]# iscsiadm -m discovery -t st -p,1 iqn.2011-11:dss-lite.target0

    then logged myself in
    [root@PCCO-XEN01 ~]# iscsiadm -m node -L all
    Logging in to [iface: default, target: iqn.2011-11:dss-lite.target0, portal:,3260]
    Login to [iface: default, target: iqn.2011-11:dss-lite.target0, portal:,3260]: successfu

    The open-e showed the following connection:
    Initiator name:

    After logging off, I tried to connect to the target
    [root@PCCO-XEN01 ~]# iscsiadm -m node -T iqn.2011-11:dss-lite.target0 -p -l
    Logging in to [iface: default, target: iqn.2011-11:dss-lite.target0, portal:,3260]
    Login to [iface: default, target: iqn.2011-11:dss-lite.target0, portal:,3260]: successfull

    another probe at the XEN results in the same error:

    [root@PCCO-XEN01 ~]# xe sr-probe type=lvmoiscsi device-config:target= device-config:targetIQN=iqn.2011-11:dss-lite.target0
    There was an SR backend failure.
    status: non-zero exit
    stderr: Traceback (most recent call last):
    File "/opt/xensource/sm/LVMoISCSISR", line 378, in ?, DRIVER_INFO)
    File "/opt/xensource/sm/", line 244, in run
    sr = driver(cmd, cmd.sr_uuid)
    File "/opt/xensource/sm/", line 128, in __init__
    File "/opt/xensource/sm/LVMoISCSISR", line 75, in load
    iscsi = driver(self.original_srcmd, sr_uuid)
    File "/opt/xensource/sm/", line 128, in __init__
    File "/opt/xensource/sm/", line 1135, in transform
    return func(inst, *args, **kwargs)
    File "/opt/xensource/sm/", line 167, in load
    File "/opt/xensource/sm/", line 170, in _initPaths
    File "/opt/xensource/sm/", line 236, in _init_adapters
    self.devs = scsiutil.cacheSCSIidentifiers()
    File "/opt/xensource/sm/", line 129, in cacheSCSIidentifiers
    line = "NONE %s %s %s %s 0 %s" % \
    IndexError: list index out of range

    I will see if I can get me some infos from the XEN Forums.
    Thanks for your help.

  2. #12


    i meant the target name, not initiatior

  3. #13
    Pi-L Guest


    If you still cant tell what is malfunctioning the ultimate test would be connect to iSCSI target for example from Windows initiator, if it works that would mean the rest is up to XEN configuration. Have you tried that?

  4. #14


    Hi Pi-L
    I thought of that. I will get me a W2k8R2 server this afternoon to check the connection to the open-e.
    I was curious to do so in the first time, since the w2k8 would be a vm on that XEN SRV. I am getting me a W2k8 labserver put on another xen, which has good iscsi plugs to a standard open-e V6.

    Keep you postetd.

  5. #15


    Hi Pi-L
    looks like it is a Problem of the installed Xen.
    I used another XENSERVER, which is just for test and lab pourpose, but basicaly not in the same IP segmnet. Putting it into an IP range which could be reached via WAN, Icould plug the open-e dss6-lite.

    Now I need to find out whats wrong with this XEN Server, since this is the same installation build as the one which could do the plugging
    Thanks for your help.

  6. #16
    Pi-L Guest


    If it is not in production yet always best way to start is to clean everything and install again..

  7. #17


    found the solution:
    I had an USB Device plugged on the Xenserver to import the vm files. Even though, it was no longer mounted, this IOMEGA HD blocked the cach of the scsiid which caused the plug from the iscsi volume to fail.

    Shoud throw it into the garbage.

  8. #18


    I also thought of this might be an XEN issue, however, have some trouble in fihuring out the real sourc of problems. Both systems are new and have never prouven to be ok.
    Last edited by Gr-R; 01-18-2012 at 12:40 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts