Visit Open-E website
Results 1 to 9 of 9

Thread: Problems connecting to NFS share from ESX4.

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Problems connecting to NFS share from ESX4.

    **Apologies if this new thread request has already reached you? I tried to post yesterday but had problems with my internet connection. If not please see below **


    I’m currently evaluating your product as a data store for VMware ESX4.0.0 Build 164009. I have downloaded and installed DSS 6.0up90.8101.5845 64bit on a HP Proliant Microserver with a 250GB HDU. The install seemed easy and quick with no problems. I setup the standard volume group vg00 and proceeded to setup a 50Gb iSCSI logical volume. I then connected to this via my ESX4 host worked fine no problem. I then setup a 50GB NAS logical volume running NFS. I also created a share called “shares” and set the NFS share access with ip address (so open to all) and Synchronous and No root squash. Then from my ESX4 server I opened the firewall for NFS access and tried to connect to the NFS share via the ip address but I get the following message “Error during the configuration of the host: NFS error: Unable to Mount filesystem: Unable to connect to NFS server”. Via the ESX console I can ping and vmkping the DSS box. Any ideas.


  2. #2
    Join Date
    Jul 2011


    NFS ports are by default random so probably they are blocked by firewall.
    If you wish to use firewall with NFS please open a support ticket on user portal and our support team will be able to provide you small update to enable fixed NFS ports to open them in firewall

  3. #3


    Thanks for the reply.

    I have been investigating further and have discoved that although the NFS option is enabled when I check the status it has failed ? Looking at the manuals the only issue I can relate to this is regarding DNS. I am simply running DHCP from my router for ip addresses and have entered the same address for the DNS settings. Is this not acceptable ? Do I need to setup a proper DNS server for me to use this option ?

  4. #4


    Try to disable the NFS service from the DSS GUI then enable it back on again. Also try to create another NFS share in the DSS and tests once more.
    All the best,

    Todd Maxwell

    Follow the red "E"
    Facebook | Twitter | YouTube

  5. #5


    I have already tried this but still the same problem ? My biggest worry is thet I can not get the NFS service to start ? Am I right in thinking that I can simply use a DHCP router and use the same address for DHCP and DNS ?

  6. #6


    There could be something wrong with the DSS and you might want to try running the Repair Filesystem from the Extended tools then reboot. If you can ping and resolve the name from the DSS in the Console Tools then your DNS is working properly.
    All the best,

    Todd Maxwell

    Follow the red "E"
    Facebook | Twitter | YouTube

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts