The 1GbE article is the same for 10GbE, try to disable scatter-gatter and TCP segmentation offload since in the Console screen go to CTRL ALT W then select Tuning options then select TCP offload options to turn those 2 options off. I heard that this might help for some Intel 10GbE NICs is to turn off the DCA Direct Cache Access, you can turn this off at the Console in CTRL ALT T then select Modify driver options and select the 10GbE NIC.