Visit Open-E website
Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: ERROR: No system volume found! System services can't work without system volume !

  1. #1

    Exclamation ERROR: No system volume found! System services can't work without system volume !

    Hi everyone, and thx for those who will be able to help

    Last week i had some troubles with my NAS. It looked like some troubles with the RAID, so i changed the RAID controller, and i also had 2 degraded disk on my RAID6 volume, that i changed.

    I started to rebuild them, but couldnt pass 51% cause of ECC-errors on a 3rd disk, so i added the option to ignore those errors.

    Then the rebuild worked.

    Now when im booting, i'm getting this error :
    ERROR: No system volume found! System services can't work without system volume !

    my RAID seems working :
    //dssA0019718> info c7

    Unit UnitType Status %RCmpl %V/I/M Stripe Size(GB) Cache AVrfy
    u0 RAID-6 OK - - 256K 18626.3 RiW OFF

    VPort Status Unit Size Type Phy Encl-Slot Model
    p8 OK u0 1.82 TB SATA - /c7/e0/slt0 ST32000644NS
    p9 OK u0 1.82 TB SATA - /c7/e0/slt1 ST32000644NS
    p10 OK u0 1.82 TB SATA - /c7/e0/slt2 ST2000NM0033-9ZM175
    p11 OK u0 1.82 TB SATA - /c7/e0/slt3 ST32000644NS
    p12 OK u0 1.82 TB SATA - /c7/e0/slt4 ST32000644NS
    p13 OK u0 1.82 TB SATA - /c7/e0/slt5 ST32000644NS
    p14 OK u0 1.82 TB SATA - /c7/e0/slt6 ST2000NM0033-9ZM175
    p15 OK u0 1.82 TB SATA - /c7/e0/slt7 ST32000644NS
    p16 OK u0 1.82 TB SATA - /c7/e0/slt8 ST32000644NS
    p17 OK u0 1.82 TB SATA - /c7/e0/slt9 ST32000644NS
    p18 OK u0 1.82 TB SATA - /c7/e0/slt10 ST32000644NS
    p19 OK u0 1.82 TB SATA - /c7/e0/slt11 ST32000644NS

    if i try to repair the FS (CAX + repair filesystem on LV, i get this message
    /var/nasexe/admintools: line 714: /sbin/xfs_repair: No such file or directory
    /var/nasexe/admintools: line 715: /sbin/xfs_repair: No such file or directory
    fsck 1.41.11 (14-Mar-2010)
    /dev/vg+vg00/config: clean, 11/8192 files, 5547/32768 blocks (check in 4 mounts)
    fsck 1.41.11 (14-Mar-2010)
    e2fsck 1.41.11 (14-Mar-2010)
    Pass 1: Checking inodes, blocks, and sizes
    Pass 2: Checking directory structure
    Pass 3: Checking directory connectivity
    Pass 4: Checking reference counts
    Pass 5: Checking group summary information
    /dev/mapper/system_crypt+d64wh5-RzGA-22jV-H52k-Lreo-ZTDW-23ACIl: 872/262144 files (24.0% non-contiguous), 29108/1048576 blocks

    Hit ENTER for reboot

    but after reboot, nothing changed.

    Are my datas lost ?

    thanks for any help !

  2. #2
    Join Date
    Oct 2010


    Run a consistency check on the raid array and see if the previous errors can be repaired.

  3. #3


    //dssA0019718> /c7/u0 start verify
    Sending start verify message to /c7/u0 ... Done.

    //dssA0019718> show alarms

    Ctl Date Severity AEN Message
    c7 [Thu Sep 17 2015 01:47:02] INFO Verify started: unit=0

    //dssA0019718> /c7/u0 show all
    /c7/u0 status = VERIFYING
    /c7/u0 is not rebuilding, its current state is VERIFYING
    /c7/u0 is verifying with percent completion = 0%(A)
    /c7/u0 is initialized.
    /c7/u0 Write Cache = on
    /c7/u0 Read Cache = Intelligent
    /c7/u0 volume(s) = 1
    /c7/u0 name = Vol1
    /c7/u0 serial number = 9WM2JY4601B83600A20A
    /c7/u0 Ignore ECC policy = on
    /c7/u0 Auto Verify Policy = off
    /c7/u0 Storsave Policy = balance
    /c7/u0 Command Queuing Policy = on
    /c7/u0 Rapid RAID Recovery setting = all
    /c7/u0 Parity Number = 2

    Unit UnitType Status %RCmpl %V/I/M VPort Stripe Size(GB)
    u0 RAID-6 VERIFYING - 0%(A) - 256K 18626.3
    u0-0 DISK OK - - p8 - 1862.63
    u0-1 DISK OK - - p9 - 1862.63
    u0-2 DISK OK - - p10 - 1862.63
    u0-3 DISK OK - - p11 - 1862.63
    u0-4 DISK OK - - p12 - 1862.63
    u0-5 DISK OK - - p13 - 1862.63
    u0-6 DISK OK - - p14 - 1862.63
    u0-7 DISK OK - - p15 - 1862.63
    u0-8 DISK OK - - p16 - 1862.63
    u0-9 DISK OK - - p17 - 1862.63
    u0-10 DISK OK - - p18 - 1862.63
    u0-11 DISK OK - - p19 - 1862.63
    u0/v0 Volume - - - - - 18626.3

    let's see if it will help, but i have doubts, because after the rebuild, there was an automatic verify, and it found nothing wrong.
    Is that the good way to check consistency on 3ware controller btw ?

  4. #4
    Join Date
    Oct 2010


    There is a good chance you will need to restore from backups. Wait and see if there are more repairs. The system volume can be rebuilt if needed.

  5. #5


    i have no backups.
    If this volume doesnt come back, i dont know what to do...

  6. #6


    and concretely, at the end of this test, what should i do ? just reboot my NAS and it should work ? or some others commands to run ?

  7. #7


    I arrived this morning at work, verify completed, without errors, but no difference, still the same error...

  8. #8
    Pi-L Guest


    System volume is a small partition used for storing configuration of most services. If it is corrupted due to hardware problem you will not be able to access the data, even if it is on completely different device.
    Each volume group has its own system volume, so in case one is corrupted you can switch to the other one (if you dont have backup of configuration just create new share/iscsi target with exiting volume to access the data).
    What you should do now is to reinstall the os to make sure boot medium is ok, or boot it from flash drive and switch default volume group to other one to use other system volume.
    If you need more help open a support ticket so support guys can help you.

  9. #9


    I bought this NAS with the system pre-installed. So i didnt receive any media to reinstall.
    I can boot the OS, still, but when i try to access my shares to manage them, it says that there is not system volume.
    I'm only having one volume group.
    right now, im running the "unit verifying" thru the 3ware bios. I don't know if it's the same at the verify thru CLI, but it looks like. It's taking exactly the same time so far... (27% so far).
    i should be done in 5h.
    so, then i can just reboot, go on the webinterface.
    If i go to configuration -> volume managers , i should see the VG0
    but i cant create a new share through configuration->NAS ressources->shares cause it's telling me there that i have no SV or something like that. So how should i create a new share ?
    by the way, if i create a new share, there is no risks that it creates a new SV that will erase my old shares ?
    my support has run out of date, so i doubt they will help me.

  10. #10
    Pi-L Guest


    if you dont have other VG create one on single HDD drive until you recover. Create new share, backup the data, then recreate the VG if you dont want support help.
    I bet you can renew your support licence.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts