Visit Open-E website
Results 1 to 2 of 2

Thread: cannot own folder

  1. #1

    Default cannot own folder

    Hi folks,

    my dss v7 runs on a server I put together on linux
    I have a share, which contains a folder I cannot delete no matter what I tried.

    - when I login over afp via osx, I see "you have custom access" and folders owner seems "unknown", group "everyone" can read&write
    - when I login over smb via windows, I see folder owner is "root (unix)"

    my full access username is "archive", pass is "archive".

    Here are my attempts so far:
    - tried taking ownership via inherit acl, nothing changed
    - tried taking ownership via windows take ownership tool, nothing changed
    - tried taking ownership via chown and batchmod, nothing changed
    - tried connecting ftp, after login I see nothing but emptiness
    - tried creating a user called "root", still cannot delete the folder
    - tried assigning my user to group "everyone", still cannot delete
    - tried connecting via ssh, all I see is ctrl+alt+some keys which access various settings, but couldnt find a command line
    - tried almost everything I know

    if I remove the share, files dont delete, so that is not an option.

    pls suggest me something I may have missed.


  2. #2
    Join Date
    Nov 2015


    Hello fuzhyperblue,

    You may first configure so called "super user", then use it to change permissions to the "archive" folder / remove it from the client system with this share mounted.
    Details are in "ACL Basics" pdf file in the attachment.

    Regarding your other attempts: as DSS is a UNIX-like system under the hood, some usernames are not allowed to be used, for example "root". Also, logging into the system via CLI similar to regular UNIX-like is not possible. You may, however, use ssh/putty to access the system's predefined functionality via API/CLI. API will allow you to automate some tasks using external scripts, while CLI is the equivalent of WebGUI, allowing you to change most of the options from within console. Please note that the console available via remote SSH CLI session is the same one you can see on a local display attached to the node.

    More information about this functionality can be found here:
    Attached Files Attached Files
    Last edited by Mi-S; 05-30-2017 at 10:28 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts