Visit Open-E website
Results 1 to 3 of 3

Thread: Unable to remove NTFS inheritence on folders

  1. #1

    Default Unable to remove NTFS inheritence on folders

    Can anyone help me on this one. I am going insane.

    First of all I'm not familiar with Linux so my perspective is from a Windows point of view and NAS configuration has been done by me purely through the web gui.

    The NAS has been iffy from day one generally but perm changing worked ok at first. Due to random disconnects and the fact the NAS refused to take an update, I was recently sent a new OS version on a USB disk due to the NAS's refusal to upgrade using the web gui. The NAS is now on Version: 5.0.NE42000000.3011

    The data from the beginning has remained on the shares but since one of the previous iffy OS upgrades NTFS perms have been acting up.

    My problem is that I cannot remove inheritance from any folders on any share). Using the administrator account from a windows box I try to set security permissions as they are required but when I click apply, Unix User and Group "root" permissions appear along with "Everybody" which has full control.
    No matter what I try I cannot remove inheritance or more worryingly "Everybody" having full control. Windows seems to perform the action then just refreshes with inheritance and those perms back.
    The folder owner appears as "DOMAIN\Administrator" so I can't see what is the problem.
    I have tried changing the NAS auth method from ADS to local then back again, have SSH'd into the NAS and "reset all permissions". Created a new test share but the same applies to folders created in that.
    In desperation I deleted the entire contents of the disk, created a new VG, new LV then new share and the same still happens.

    It's worth noting that there are no ticks for "Everyone" in the inital security window, but when you click on advanced it says they have "Full Control" and sure enough a plain user who is a member of no specific groups has full access to the folder.

    Mr Desperate

  2. #2


    In Windows can you set the security so that everyone has no access, then apply then set access to set only the special permissions.

  3. #3
    Join Date
    Jan 2008


    Also, it may be you ADS.. eliminate it from the process what happened?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts